iOS 5 からUIAlertView上に表示されるボタンのクラス名が変更された模様

iOS 5からUIAlertView上に表示されるボタンのクラス名が変更されたみたいです。

もともとは「UIThreePartButton」という名前だったのですが、iOS 5からは「UIAlertButton」という名前になりました。

後者のほうがより直感的にわかりやすいクラス名になったと思います。

このクラスのインスタンスを直接生成することはないかと思いますが、以下のページで紹介されているような方法でデフォルトのUIAlertViewをカスタマイズする場合、ボタンの表示位置を調整するためにこのクラス名が必要になってきます。

こんな感じ。

iOS 5のリリース以前にカスタマイズしたUIAlertViewを使ったアプリを開発した人、これから開発しようとしている人は注意が必要ですね。